网站地图    梁伟介绍    标签云    登陆注册
首页 > 网络技术 > 思科设备如何配置DHCP
20131月8

思科设备如何配置DHCP

分类:网络技术 | 标签:, | 浏览:2,071次 2 Comments 发表评论

思科设备如何配置DHCP

今天有人qq上找我问我思科设备如何配置dhcp,那么我就把我今天给他做的方案发出来给大家分享一下。

客户需求:

1.同时为多个VLAN的客户机分配地址
2.VLAN内有部分地址采用手工分配的方式
3.为客户指定网关、Wins服务器等
4.VLAN 2的地址租用有效期限为1天,其它为3天
5.按MAC地址为特定用户分配指定的IP地址

最终配置如下:

ip dhcp excluded-address 10.1.1.1 10.1.1.19            //排除的地址范围,不用于动态地址分配的地址
ip dhcp excluded-address 10.1.1.240 10.1.1.254
ip dhcp excluded-address 10.1.2.1 10.1.2.19
!
ip dhcp pool global        //global是pool name地址池的名字, 由用户指定,随便写不过一定写的通俗最起码自己要能看懂
network 10.1.0.0 255.255.0.0              //动态分配的地址段(将要分配给用户的地址)
dns-server 10.1.1.1 10.1.1.2                //为客户机配置dns服务器
netbios-name-server 10.1.1.5 10.1.1.6         //为客户机配置wins服务器(这个根据情况设置,一般不需要)
netbios-node-type h-node             //为客户机配置节点模式(影响名称解释的顺利,如h-node=先通过wins服务器解释)
lease 3                                                            //地址租用期限: 3天
ip dhcp pool vlan1
network 10.1.1.0 255.255.255.0                //本pool是global的子pool, 将从global pool继承domain-name等option
default-router 10.1.1.100 10.1.1.101         //为客户机配置默认网关
!
ip dhcp pool vlan2                                     //为另一VLAN配置的pool
network 10.1.2.0 255.255.255.0
default-router 10.1.2.100 10.1.2.101
lease 1
!
ip dhcp pool vlan1_liangwei        //总是为MAC地址为010050.bade.6384的机器分配10.1.1.21地址
host 10.1.1.21 255.255.255.0
client-identifier 010050.bade.6384 //client-identifier=01加上客户机网卡地址
!
ip dhcp pool vlan1_liangwei5
host 10.1.1.50 255.255.255.0
client-identifier 010010.3ab1.eac8

相关的DHCP调试命令:
no service dhcp                  //停止DHCP服务[默认为启用DHCP服务]
sh ip dhcp binding                 //显示地址分配情况
show ip dhcp conflict             //显示地址冲突情况
debug ip dhcp server {events | packets | linkage}              //观察DHCP服务器工作情况

如果DHCP客户机分配不到IP地址,常见的原因有两个。

1.第一种情况是没有把连接客户机的端口设置为Portfast方式。MS客户机开机后检查网卡连接正常,Link是UP的,就开始发送DHCPDISCOVER请求,而此时交换机端口正在经历生成树计算,一般需要30-50秒才能进入转发状态。MS客户机没有收到DHCP SERVER的响应就会给网卡设置一个169.169.X.X的IP地址。解决的方法是把交换机端口设置为Portfast方式:CatOS(4000/5000/6000): set spantree portfast mod_num/port_num enable; IOS(2900/3500): interface … ; spanning-tree portfast。

2.另外一种情况是DHCP服务器和DHCP工作站不在同一个VLAN,这时候通常通过设置中继ip helper-address来解决:

interface vlan1
ip address 10.1.1.254 255.255.255.0 //假设DHCP服务器地址为10.1.1.8
interface Vlan2
ip address 10.1.2.254 255.255.255.0
ip helper-address 10.1.1.8             //假设这是DHCP客户机所在的VLAN

 

这个就是一个思科设备配置dhcp的案例,这个只是一个案例,实际应用可以根据需求来修改。

文章作者:梁伟
本文地址:http://www.liangwei.cc/net_tech/si_ke_she_bei_ru_he_pei_zhi_dhcp.html
版权所有 © 转载时必须以链接形式注明作者和原始出处!

有2 条评论 to “思科设备如何配置DHCP”

  1. #1 xiaoyu 回复 | 引用 评论时间 : 2014-06-16 16:17

    如果在思科模拟器上我不想用命令,配置dhcp服务,直接在服务器中配置,能不能实现,该怎么实现

    • #2 梁伟 回复 | 引用 评论时间 : 2014-06-16 17:46

      可以啊,但是你在windows或者linux服务器上做DHCP,如果分配多个网段的IP,需要在交换机开启DHCP中继,配置一下中继就可以了。

发表评论